did i kill them??

so i work alot, alot, alot. came home 2 nights ago after being gone for 4 days. 2 of my purple urkles were in bad shape!! the whole lower half of the plants were dead. i mean leaves dried crisp yellow gone!!! here is a pic of 3 of the leaves that are toward the top of the plant that i plucked off tonight. i took a pic of them on the plant but you cant see shit under the hps light.the top if the plants are fine. i will put a pic of them in the scrog but you cant really tell. it is the one on the lower left that is the worst but if you can tell the top looks fine. what do you think, just under watering death or something under nutes?? what you think guys this is my first grow by the way

  1. You will see these arrows in every question page. They allow you to upvote/downvote according to the relevancy of the question/answer.
  2. Edit your question/answer if you wish to change it or update it.
  3. If you dont understand something about the question, leave a comment asking. The answer field should be only used for answers.
  4. If the author of a question mark an answer as solution, this mark will be visible.
  5. Click here to see more details about the operation of the system!

1 answer

  • You have a nutrient imbalance, it looks like a phosphorous deficiency. Now that does not mean you need to add more of that because other elements can block the uptake of it like calcium and magnesium. Also, make sure your pH is correct. When in doubt give it a flush and then feed with a half strength after that. 


It is not the answer you were looking for? Search other questions with the tags or make your own question.